Improvado Inc. - Delay in the work of extraction orders – Incident details

All systems operational

Delay in the work of extraction orders

Resolved
Major outage
Started about 1 month agoLasted about 15 hours

Affected

Improvado Platform

Operational from 10:30 AM to 7:45 PM, Major outage from 7:45 PM to 9:23 PM, Degraded performance from 9:23 PM to 1:18 AM

AI Agent

Operational from 10:30 AM to 7:45 PM, Major outage from 7:45 PM to 12:12 AM, Degraded performance from 12:12 AM to 1:18 AM

Data Extraction

Degraded performance from 10:30 AM to 4:00 PM, Operational from 10:30 AM to 7:45 PM, Major outage from 7:45 PM to 12:12 AM, Degraded performance from 12:12 AM to 1:18 AM

Data Sources

Degraded performance from 10:30 AM to 4:00 PM, Operational from 4:00 PM to 7:45 PM, Major outage from 7:45 PM to 12:12 AM, Degraded performance from 12:12 AM to 1:18 AM

Facebook

Degraded performance from 10:30 AM to 4:00 PM, Operational from 4:00 PM to 7:45 PM, Major outage from 7:45 PM to 12:12 AM, Degraded performance from 12:12 AM to 1:18 AM

Google Universal Analytics

Degraded performance from 10:30 AM to 4:00 PM, Operational from 4:00 PM to 7:45 PM, Major outage from 7:45 PM to 12:12 AM, Degraded performance from 12:12 AM to 1:18 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We implemented a fix and are currently monitoring the result.

  • Update
    Update
    We are continuing to work on a fix for this incident.
  • Identified
    Identified

    Incident Summary:

    We have identified a database issue in our internal infrastructure that is currently affecting multiple services.

    Affected Services:

    • Data Extraction

    • Data Load

    • AI-Agent

    Impact:

    The above services are currently down. Data refresh and delivery to your dashboards are temporarily unavailable.

    Root Cause:

    Internal database malfunction requiring emergency restoration procedures.

    Current Status:

    Our technical team is performing emergency maintenance to restore service as soon as possible.

    Expected Resolution:

    The database restoration process will take approximately 2-3 hours. We expect all services to resume normal operations within 4 hours.

    Next Steps:

    • Emergency maintenance in progress

    • All affected services will automatically resume once restoration is complete

    • We will send a follow-up notification once the issue is fully resolved

    We sincerely apologize for any inconvenience this may have caused. If you have any questions or concerns, please don't hesitate to contact our support team.

  • Monitoring
    Monitoring

    We implemented a fix and are currently monitoring the result. The data will be updated within a couple of hours.

  • Investigating
    Investigating

    Due to a short‑term glitch in the logic of the extraction orders, some of the data was pulled up with empty fields. Our development team is already working on solving the problem.