Improvado Inc. - Data Extraction Delay – Incident details

All systems operational

Data Extraction Delay

Resolved
Degraded performance
Started 5 months agoLasted about 5 hours

Affected

Data Extraction

Degraded performance from 11:09 AM to 4:01 PM

Data Sources

Degraded performance from 11:09 AM to 4:01 PM

Facebook

Degraded performance from 11:09 AM to 4:01 PM

Google Universal Analytics

Degraded performance from 11:09 AM to 4:01 PM

Google Ads

Degraded performance from 11:09 AM to 4:01 PM

Adobe Analytics Data Feed

Degraded performance from 11:09 AM to 4:01 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    Incident Description:

    An internal issue was identified within our data delivery infrastructure, which resulted in a delay in the delivery of data. The root cause was linked to a performance bottleneck in our system. A fix was implemented to address the issue and enhance the overall performance and stability of our system. However, this fix has resulted in an additional anticipated delay in data delivery.

    Current Status:
    The system is currently stable with an ongoing monitoring process in place. Data delivery has resumed but is operating under a 3-hour delay as the system stabilizes.

    Expected Resolution Time:

    Normal data delivery schedules are expected to resume after the 3-hour delay period from the time of fix implementation.

    We apologize for any inconvenience caused by this delay and are committed to ensuring the reliability and timeliness of our services. Our team is dedicated to continuous improvement and will take all necessary steps to prevent such incidents in the future.

  • Investigating
    Investigating

    We are currently facing some delays in our extraction and load processes. Please be assured that our team is diligently working to identify and resolve the issue promptly.