Improvado Inc. - Data Extraction Delay – Incident details

All systems operational

Data Extraction Delay

Resolved
Degraded performance
Started 5 months agoLasted about 9 hours

Affected

Data Extraction

Degraded performance from 6:30 AM to 3:33 PM

Data Sources

Degraded performance from 6:30 AM to 3:33 PM

Facebook

Degraded performance from 6:30 AM to 3:33 PM

Google Universal Analytics

Degraded performance from 6:30 AM to 3:33 PM

Google Ads

Degraded performance from 6:30 AM to 3:33 PM

Adobe Analytics Data Feed

Degraded performance from 6:30 AM to 3:33 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    Incident Description:
    We have identified a significant issue within our data extraction infrastructure that resulted in delays in data delivery. The root cause was pinpointed as a performance bottleneck. In response, we implemented a corrective measure aimed at enhancing both the performance and stability of our operations. While this intervention was necessary, it has caused an additional, though expected, delay in data delivery.

    Current Status:
    The system is currently stable, and we have resumed data delivery, albeit with a delay. We have implemented ongoing monitoring to ensure the system's continued stability as it returns to normal operations.

    Expected Resolution Time:
    Normal data delivery schedules are expected to resume approximately 3 hours from the implementation of the corrective measures.

  • Investigating
    Investigating

    We are currently experiencing unexpected delays in our data extraction processes. Our technical team has been notified and is actively investigating the root cause of these delays. We are committed to resolving this issue as quickly as possible and minimizing any impact on our services.