Improvado Inc. - Order Processing Delays – Incident details

All systems operational

Order Processing Delays

Resolved
Degraded performance
Started 4 months agoLasted about 3 hours

Affected

Data Extraction

Degraded performance from 2:00 PM to 4:48 PM

Data Sources

Degraded performance from 2:00 PM to 4:48 PM

Facebook

Degraded performance from 2:00 PM to 4:48 PM

Google Universal Analytics

Degraded performance from 2:00 PM to 4:48 PM

Google Ads

Degraded performance from 2:00 PM to 4:48 PM

Adobe Analytics Data Feed

Degraded performance from 2:00 PM to 4:48 PM

Updates
  • Resolved
    Resolved

    The issue affecting order status displays and data availability has been resolved. All systems are now operating normally.

    We appreciate your patience and apologize for any inconvenience caused. If you experience any issues, please reach out to our support team.

  • Investigating
    Investigating

    We are currently experiencing an issue that may impact the way order statuses are displayed in the client UI. Some orders might not reflect their most up-to-date status, and there could be slight delays in data availability.

    Our team is actively investigating and working to resolve the issue as soon as possible. We appreciate your patience and will provide updates as they become available.