Improvado Inc. - Data Extraction Delay – Incident details

All systems operational

Data Extraction Delay

Resolved
Degraded performance
Started about 2 months agoLasted about 4 hours

Affected

Data Extraction

Degraded performance from 10:00 AM to 1:32 PM

Data Sources

Degraded performance from 10:00 AM to 1:32 PM

Facebook

Degraded performance from 10:00 AM to 1:32 PM

Google Universal Analytics

Degraded performance from 10:00 AM to 1:32 PM

Google Ads

Degraded performance from 10:00 AM to 1:32 PM

Adobe Analytics Data Feed

Degraded performance from 10:00 AM to 1:32 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    Incident Description:
    We have identified an issue within our infrastructure that resulted in delays in data delivery. The root cause was pinpointed as a performance bottleneck. In response, we implemented a corrective measure aimed at enhancing both the performance and stability of our operations. While this intervention was necessary, it has caused an additional, though expected, delay in data delivery.

    Current Status:
    The system is currently stable, and we have resumed data delivery, albeit with a delay. We have implemented ongoing monitoring to ensure the system's continued stability as it returns to normal operations.

    Expected Resolution Time:
    Normal data delivery schedules are expected to resume approximately 2 hours from the implementation of the corrective measures.

  • Investigating
    Investigating
    We are currently investigating this incident.